Vamos a ver los primeros pasos para la configuración de VLAN's, en este caso con Cisco.

Disponemos de un conmutador Cisco Catalyst 2950 y de un router Cisco Catalyst 2600.

 

Para crear VLANs, el switch debe estar en modo VTP “Server”, o “Transparent”. “Server” es el default.

 

show vtp status

show vlan

vlan database

vtp server

vlan 2 name admin (crear la VLAN)

vlan 3 name comercial

...

exit

show vlan

configure terminal

interface f0/1

switchport access vlan 2 (asigna el puerto a la VLAN 2)

interface f0/2

...

end

Ver también: interface range, para configurar varias interfaces a la vez.

Para borrar una vlan:

vlan database

no vlan 2 (borrar la VLAN especificada)

 

Para quitar la asignación de VLAN a un puerto:

configure terminal

interface f0/1

no switchport access vlan 2

 

Para volver todo el switch al default de fábrica (ver http://www.cisco.com/warp/public/473/156.html):

erase startup-config (borra configuración, excepto VLAN)

delete flash:vlan.dat (borra la información de VLAN)

reload

 

Enrutamiento entre VLANs

Ejemplo: Configurar un solo switch con dos diferentes VLANs (con los comandos de arriba). Conmutar el tráfico entre las dos VLANs con un router.

Una troncal del switch se conectará a una interface FastEthernet del router, la cual se subdivide en dos sub-interfaces (una para cada VLAN).

Comandos para el switch:

vtp mode transparent

o también: vtp mode server

(El default es "server", que sirve para este ejercicio.)

interface F0/5

switchport mode trunk

(comandos para encapsulación)

switchport trunk allow vlan all

El switch 2950 sólo soporta un encapsulamiento, y no soporta comandos para cambiar el encapsulamiento. Sin embargo, es importante recordar que en otros switches posiblemente se tenga que seleccionar el encapsulamiento correcto (dot1q, o isl).

Comandos para el router:

interface F0 (o: F0/0)

no shutdown

interface F0.2 (o: F0/0.2) (selecciona una sub-interface)

encapsulation dot1q 2

ip address ...

interface F0.3

encapsulation dot1q 3

ip address ...

(Repetir para cada VLAN.)

 

Comandos para los hosts:

Obviamente, aparte de configurar el router y el switch, también se deben configurar los hosts conectados. Específicamente, se tiene que asignar:

·        La dirección IP. Se debe recordar que (1) la dirección IP debe estar en la misma subred que la sub-interfaz correspondiente del router, y (2) para la configuración de VLANs en general, diferentes VLANs corresponden a diferentes subredes.

·        La máscara de subred.

·        La puerta de enlace, que debe apuntar a la sub-interfaz correspondiente de router.

 

Referencias:

VLANS en general: http://www.cisco.com/warp/public/793/lan_switching/3.html

Switching entre VLANs: http://www.cisco.com/en/US/tech/tk389/tk390/technologies_configuration_example09186a00800949fd.shtml

Para otros switches o routers, por favor buscar en la documentación de Cisco Systems. (Una búsqueda en Internet es muy útil en este caso.)

 

Joomla templates by a4joomla